Commandes

Vider le cache

Suivant l'environnement

$ php app/console cache:clear 
$ php app/console cache:clear --env=prod
$ php app/console cache:clear --env=dev

Installer les assets

$ php app/console assets:install --symlink

Création d'un bundle

$ php app/console generate:bundle

Doctrine

Voir aussi Chapitre Doctrine

Création d'une entité

le shortcut name doit être de la forme MachinTrucBundle:NomEntite

$ php app/console generate:doctrine:entity

Base de données

Pour créer la base de données

Voir aussi le paramétrage pour la base de données paramétrages de Symfony2
php app/console doctrine:database:create

Pour voir la/les requêtes SQL qui créé/modifie la base

php app/console doctrine:schema:update --dump-sql

Pour exécuter les requêtes

php app/console doctrine:schema:update --force

Composer

Ne sont notées que les commandes utilisées avec Symfony2 Pour l'utilisation de composer en général, encore un tuto vidéo sympa de Grafikart PHP :composer

Installation

$ php -r "readfile('https://getcomposer.org/installer');" | php

Mise à jour de composer

php composer.phar self-update

Installation des bundles

php composer.phar install

Dans composer.lock, on a la version utilisée pour chaque bundle.

La liste des dépendances est enregistrée dans le fichier composer.json comme dans l'exemple ci-dessous. (En installant Symfony2, on installe déjà des bundles par défaut).

{
    "name": "symfony/framework-standard-edition",
    "license": "MIT",
    "type": "project",
    "description": "The \"Symfony Standard Edition\" distribution",
    "autoload": {
        "psr-0": { "": "src/", "SymfonyStandard": "app/" }
    },
    "require": {
        "php": ">=5.3.3",
        "symfony/symfony": "2.5.*",
        "doctrine/orm": "~2.2,>=2.2.3",
        "doctrine/doctrine-bundle": "~1.2",
        "twig/extensions": "~1.0",
        "symfony/assetic-bundle": "~2.3",
        "symfony/swiftmailer-bundle": "~2.3",
        "symfony/monolog-bundle": "~2.4",
        "sensio/distribution-bundle": "~3.0",
        "sensio/framework-extra-bundle": "~3.0",
        "incenteev/composer-parameter-handler": "~2.0",
        "liuggio/excelbundle": "~2.0",
        "ua-parser/uap-php": "*"
    },
    "require-dev": {
        "sensio/generator-bundle": "~2.3"
    },
    "scripts": {
        "post-root-package-install": [
            "SymfonyStandard\\Composer::hookRootPackageInstall"
        ],
        "post-install-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::removeSymfonyStandardFiles"
        ],
        "post-update-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::removeSymfonyStandardFiles"
        ]
    },
    "config": {
        "bin-dir": "bin"
    },
    "extra": {
        "symfony-app-dir": "app",
        "symfony-web-dir": "web",
        "incenteev-parameters": {
            "file": "app/config/parameters.yml"
        },
        "branch-alias": {
            "dev-master": "2.5-dev"
        }
    },
}

Mise à jour des bundles

Tout mettre à jour :

php composer.phar update

Mette à jour un bundle :

php composer.phar update nomBundle